Results 1 to 9 of 9

Thread: SSD troubles

  1. #1

    Default SSD troubles

    Cut a long story short, my main harddrive is failing, im getting alot of smart errors on it, funny enough this is my Games drive/Windows drive so it was probily the reason why my windows froze up at times and even restarted my pc when i was in games.

    So I finally got my self a 2x OCZ Vertex 3 SSD drive(One drive is for friend).I honestly could not update firmware due to half the machines I have at work and at home has IDE configurations, soon as I switch to ACHI mode in the BIOS windows just wont go in(BSOD).

    Clarify this if possile - You are able to go into safe mode and switch windows to use AHCI mode instead of IDE through editing some reg keys?If so where the?

    Ok so now to the real problem, so about 10 pm last night I just had enough and pulled all drives out except the SSD's, windows started it thirteen year journey of trying to install, it starts up fine and everything, extracts the files to the drive, but as soon as it hits Excuting applications. bam i get an error, I have tried it about twice last night.

    After doing some research while trying to get some sleep, I stumble upon my motherboards driver downloads and see under the SATA section that there is a driver for ACHI (However I always thought this was for RAID systems which im not wanting to run).
    So now im going to download that tonight and hopefully get windows to use this driver before installing..
    (I hope this works)..Any advice would be appreciated.

    Also take note that I also tried installing on the Spare SSD with same result.


    Hardware specs:-

    CPU:- i7 D920 - 2.6Ghz
    Mobo:- Asus P6T Delux V2 1366
    RAM:- 6 GB - 1033 Mhz
    PSU:- 1000W Corsair Modular
    GPU:- 1X GTX 590 (another on the way)


    Edit:

    Yeah I did update BIOS to the latest version 1202 but the update only fixes known logitech problems.
    Yip it looks like Driver for SATA is "Intel(R) AHCI/RAID Driver Disk for Windows 32/64bit XP & Windows 32/64bit Vista & 32/64bit Windows 7"

    Thing is i dont want to Raid them, But i know when XP was out and the new SATA technology came out you had to have Drivers, so i thoght the above should help just like XP days.
    Last edited by ArchieChoke; 07-06-2012 at 10:26 AM. Reason: Added information gathered from other Forum.

  2. #2

    Default

    just to clarify what windows are you using xp or 7. xp does not support native sata if you want to use sata with xp you need to load a driver during the xp install or make a xp cd that has the driver bundled with it using this http://www.nliteos.com/ see write up here http://www.sevenforums.com/tutorials...ows-xp-cd.html

    okay so i read your post again and i assume its win7, what error does it bomb with?
    if its getting as far as what your describing that means the sata driver is fine and working or it would not have copied anything or detected the drive
    Last edited by B1nary; 07-06-2012 at 12:41 PM. Reason: update

  3. #3

    Default

    Quote Originally Posted by B1nary View Post
    just to clarify what windows are you using xp or 7. xp does not support native sata if you want to use sata with xp you need to load a driver during the xp install or make a xp cd that has the driver bundled with it using this http://www.nliteos.com/ see write up here http://www.sevenforums.com/tutorials...ows-xp-cd.html

    okay so i read your post again and i assume its win7, what error does it bomb with?
    if its getting as far as what your describing that means the sata driver is fine and working or it would not have copied anything or detected the drive
    Yeah sorry wasnt very clear, trying to install windows 7 at this point. Like i said before it has no trouble finding the drive, its just the last bit of win7 installation that fails, i will get a print screen of the error.i was thinking that the ssd could be faulty but i have 2 of them so chances are that 2 drives faulty is unlikely but possible.

    Yeah i thought the same thing but then seeing a driver from asus raises a eyebrows as it says windows 7.

    I am actually interested how windows installs itself,the initial start phase takes a while to load,which i can believe its because of DVD technology,however when it copies files,where is it storing it,to RAM,then when you select the drive does it extract that info into the drive selected?

    Someone thinks its Ram.

  4. #4

    Default

    Also check the different settings in the BIOS (for hard disks specifically), I had endless shit with a normal SATA drive, and I played around with all the BIOS settings, and now I haven't had problems again.
    I think you get (depending on your motherboard):
    - Sata
    - Raid (even if you do not raid the drives)
    - AHCI
    - Compatibility mode
    - IDE emulation(yes, for a sata only hdd)

    I have changed mine from one to the other (cannot remember which) and this made the drive work.
    Last edited by TBlaar; 24-09-2012 at 12:04 PM.

  5. #5

  6. #6

    Default

    Archie..

    YOu have marvel controller and they completely F out on sata 3 marvel controllers. You need to load marvel drivers and sort it out . I was constantly getting errors so i eventually popped it into a sata 2 port and works fine till this day. But the hotfix back then was .


    Set it to the correct setting ACHI or IDE and install windiows after having the Load disk option to load marvel controllers. Then install .

    Not worth it. Run on sata 2 and not your marvell sata 3 the drive will be fast enough. Make sure you update its firmware first.

  7. #7

    Default

    Have you tried loading the drivers before you install windows on the screen where you can format and partition the drive there is an option to do so.

    im curious to see what happens if you do change it to sata 2 without changing anything.

  8. #8

    Default

    Marvel controllers with a SATA 3 SSD do not mix.

    Rather run the SSD's off the Intel or Jmicron controllers, and set them to AHCI.

    That's all you will ever need to do.

    Haven't checked the specs of your board out, but you should have at least 2 different controllers.

  9. #9

    Default

    Managed to sort it all out.

    Thanks for the help, got it sorted by taking all drives out, left the SSD,Set to ACHI, downloaded the Marvell 61XX SATA Driver (http://dl.dropbox.com/u/7525007/Untitled.png), started windows install, when i got to drive selection, formated drive, loaded SATA driver then proceeded to finish installation.

Similar Threads

  1. Thread of PC Woes, Troubles, Problems, and Issues
    By Isengard in forum Hardware and Gadgets
    Replies: 1174
    Last Post: 22-06-2017, 11:31 AM
  2. Help with PC troubles
    By Tchnlgydude in forum Off Topic
    Replies: 14
    Last Post: 07-12-2011, 02:47 AM
  3. MyGaming photo section uploading troubles?
    By James in forum Off Topic
    Replies: 11
    Last Post: 22-11-2011, 03:42 PM
  4. PC troubles
    By Shamrock in forum Hardware and Gadgets
    Replies: 16
    Last Post: 19-05-2009, 10:06 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •