Page 5 of 118 FirstFirst ... 3 4 5 6 7 15 55 105 ... LastLast
Results 41 to 50 of 1175

Thread: Thread of PC Woes, Troubles, Problems, and Issues

  1. #41

    Default

    I'm having a problem with my mouse. It randomly disconnects and reconnects.

    My USB mouse (SteelSeries IKARI Laser) keeps randomly disconnecting for 2 seconds and then reconnects. My entire computer freezes for a split second during the disconnect and reconnect phase. I cannot use my mouse when it is disconnected at all, until it is reconnected. All that happens is that I hear the Windows bing sound, indicating that a USB device has been removed, and then I heard another sound indicating a USB device has been inserted. The disconnects occur at random intervals. Sometimes 30 minutes, sometimes 1 minute.

    This randomly started happening today after I restarted my PC. I have no viruses or malware on my PC. I reinstalled the drivers, and no help. This problem is very persisting. Please, any help will be appreciated, as I have never seen a problem such as this before.

    Note: there's a light on my mouse that remains on at all times even when my mouse disconnects and is incapable of moving. This means that there is still power going to the mouse, and it is not a USB socket problem.

  2. #42

    Default

    I reckon u have a break in your cord somewhere. Try it on another pc to see if u get the same issues, if indeed u have an issue.
    That mouse carries a 3yr warranty on it, so just send it in and let em send u another

  3. #43

    Default

    The cord appears to be fine. I'll try using it on a different PC and see if it persists, but I'm afraid that the problem might be on my PC, rather than the mouse itself. So I doubt a replacement will fix it :/ I've never had a problem with this mouse.

  4. #44

    Default

    you never know, try it on another. I hope this is an easy fix. I don't forsee it bein an usb issue. Could be something loose inside the mouse too, weirder things have happend

  5. #45

    Default

    I tried it on another Windows computer, and it never gave me this particular error after almost an hour of use.

    I have run three different Anti-virus app's, and none of them throw anything at me, except for Malwarebyte's Antimalware, which has picked up a worm... First virus I find on my PC in a while. It might be the cause of this problem. I kinda hope that's the cause :P I don't wanna go through a warranty debacle.

  6. #46

    Default

    Fixed :P was probably the worm

  7. #47

    Default

    Ok, I restarted my PC this morning and the problem is back. I tested the mouse on another PC and no problems with it. So, I have no idea what to do... any help is appreciated.

  8. #48
    MyGaming Comp Authoritah sycogrim's Avatar
    Join Date
    Feb 2009
    Location
    Unitedstates of JHB/Randburg
    Posts
    31,085

    Default

    if you go to Control Panel----- Admin Tools----- Computer Management-----Device Manager and just uninstall ur USB drivers (all of them) and just scan for hardware changes and try that if you get an exclamation ur hardware might have 1 of 2 issues either its the usb hardware itself or its the firmware/drivers try updating the drivers for ur board then if it does it again just rollback the drivers which should roll them back to when they were first installed almost like a recovery but just for the usb
    All it takes is ONE BAD DAY tO ReDuCe the SaNesT Man Alive To LuNaCy. That's How Far The World Is From Where I am. JUST ONE BAD DAY

    Blog Entries . YouTube Channel and Playlists

    Quote Originally Posted by ShadowFox
    I'm gonna tolerate and love...........THE SHIT OUTTA YOU
    Shadowfox's response to me in my failed attempts to annoy him

  9. #49

    Default

    Update the firmware of your mouse, go to there website and get the latest. sounds like a firmware issue.

    my razer did this aswell.

  10. #50

    Default

    Is it really a good idea to uninstall the drivers? I don't believe its a driver issue anyways, and I'm afraid because last time I kinda messed around and then I had to reinstall Windows... I don't want that again :/

    I have already tried to reinstall the firmware. No new firmware has been released since I bought the mouse.
    Last edited by Vixe; 05-10-2009 at 11:23 AM.

Similar Threads

  1. GPU troubles
    By [email protected] in forum Hardware and Gadgets
    Replies: 5
    Last Post: 27-03-2014, 11:37 AM
  2. Homefront 2 is coming along fine despite THQ's troubles
    By Jeremy in forum Gaming News Articles
    Replies: 1
    Last Post: 22-06-2012, 12:31 PM
  3. SSD troubles
    By ArchieChoke in forum Hardware and Gadgets
    Replies: 8
    Last Post: 07-06-2012, 08:32 PM
  4. Help with PC troubles
    By Tchnlgydude in forum Off Topic
    Replies: 14
    Last Post: 07-12-2011, 02:47 AM
  5. PC troubles
    By Shamrock in forum Hardware and Gadgets
    Replies: 16
    Last Post: 19-05-2009, 10:06 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •